二维码
搬瓦工 locvps

前几天尝试在服务器中安装Discuz! Q程序的时候,由于根据官方的安装文档是通过Composer安装的,而且在安装过程中出现问题,我就检查到底是哪里出现问题。首先我检查看看是不是当前默认的服务器WEB系统没有安装Composer。

解决检查composer安装时提示"putenv() has been disabled"解决方法

我们可以检查composer的时候有提示"putenv() has been disabled"问题。那肯定是在php.ini中有限制这个函数,这里我们需要将其取消禁止。

这里我们在配置文件中找到putenv,直接这个函数定义删除即可。这个问题就解决,但是后来我发现还有一个函数需要禁止。

同样的方法,我们禁止函数。

这里我们再检测composer是没有报错的。问题解决。


locvps
评论专区
  • 昵 称必填
  • 邮 箱必填
  • 网 址选填
◎已有 0 人评论
BudgetVM
作者介绍
转载大师

转载大师

转载大师作为本站编辑,主要负责把优秀的文章转载至此。如果您认为本文侵犯了您的版权信息,请与转载大师联系修正。
80vps henghost
budgetvm sugarhosts
二维码

分享:

支付宝

微信